Google Ads Audiences Not Sending to Google
Incident Report for Clearbit
Resolved
This issue has been resolved - Ads Audiences processed over the weekend, and are now correctly synchronizing to Google.
Posted Oct 21, 2024 - 10:16 PDT
Update
We have fixed the issue, and are processing the affected Audiences to resynchronize them to Google.
Posted Oct 18, 2024 - 14:20 PDT
Identified
We are having issues with Google Ads Audiences sending to Google. We have identified the problem and are working on a fix.
Posted Oct 18, 2024 - 12:36 PDT
This incident affected: Clearbit Data Activation Platform (Platform UI).