Audience results delayed

Incident Report for Clearbit

Resolved

This incident has been resolved. Audience results and destination deliveries are back to normal timing.
Posted Mar 27, 2025 - 19:31 PDT

Monitoring

We have implemented a fix and are monitoring the results. Results for new Audiences and destinations should be back to normal now.
Posted Mar 26, 2025 - 16:37 PDT

Update

We are still working on a fix for this issue.
Posted Mar 25, 2025 - 17:58 PDT

Update

We are continuing to work on a fix for this issue.
Posted Mar 24, 2025 - 17:51 PDT

Identified

We have identified the issue and are implementing a fix.
Posted Mar 21, 2025 - 14:33 PDT

Update

We continue to investigate this issue to fully understand the root cause before moving on to implementing a fix. During this time, the delay in Audience results may fluctuate — some updates may process more quickly, but delays of up to 5 hours are still possible.
Posted Mar 20, 2025 - 16:30 PDT

Update

We are continuing to investigate this issue. We will continue to post updates as we make progress.
Posted Mar 19, 2025 - 15:05 PDT

Investigating

Audience results may experience delays of up to 5 hours. This delay only affects new Audience results or destination deliveries that are triggered during this window.
Posted Mar 18, 2025 - 13:18 PDT
This incident affected: Clearbit Data Activation Platform (Platform UI) and Webhooks.