Service Disruptions Due to Google Cloud Outage

Incident Report for Clearbit

Resolved

All services are back to operating normally.
Posted Jun 12, 2025 - 19:57 PDT

Update

Google Cloud has resolved the underlying issue with the services we use, and Clearbit services are beginning to recover. We're continuing to monitor system performance to ensure full restoration.
Posted Jun 12, 2025 - 15:03 PDT

Monitoring

Multiple Clearbit services are currently experiencing disruptions due to a broader outage impacting Google Cloud Platform. This may result in degraded performance or temporary unavailability for some features. We're actively monitoring the situation and will provide updates as more information becomes available.
Posted Jun 12, 2025 - 13:27 PDT
This incident affected: Dashboard.