Clearbit X events, segment calculations, and destination deliveries delayed
Incident Report for Clearbit
Resolved
This incident has been resolved.
Posted Feb 19, 2020 - 00:32 PST
Investigating
We are currently investigating this issue.
Posted Feb 18, 2020 - 23:12 PST
This incident affected: Clearbit Data Activation Platform (API, Platform UI, Forms).