Clearbit X segment results and destination deliveries are delayed
Incident Report for Clearbit
Resolved
This incident has been resolved.
Posted Feb 13, 2020 - 15:25 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 13, 2020 - 14:35 PST
This incident affected: Clearbit X (API, UI).