Clearbit X event processing delayed
Incident Report for Clearbit
Resolved
This incident has been resolved.
Posted Feb 19, 2021 - 11:09 PST
Monitoring
We have investigated a slow down in the rate at which Clearbit X processes analytics and page views. We've implemented a fix and are monitoring the situation until it is resolved.
Posted Feb 11, 2021 - 17:37 PST
This incident affected: Clearbit X (UI).