Audience results delay

Incident Report for Clearbit

Resolved

This incident has been resolved. Company and Person Audiences are functioning as normal.
Posted Feb 13, 2026 - 01:53 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 12, 2026 - 06:54 PST

Update

We are continuing to work on a fix for this issue.
Posted Feb 12, 2026 - 03:06 PST

Identified

We have identified an issue that prevents audience processing. We found the root cause and are implementing a fix.
Posted Feb 11, 2026 - 12:46 PST

Investigating

We're currently experiencing an issue that's preventing Audiences from being processed for some customers. Processing will resume once a fix is in place. We're actively working to resolve the issue and will share updates as they become available.
Posted Feb 11, 2026 - 10:30 PST
This incident affected: Dashboard and Clearbit Data Activation Platform (Platform UI).