Delayed Form and Event Processing
Incident Report for Clearbit
Resolved
This incident has been resolved.
Posted 3 months ago. Jan 31, 2019 - 07:29 PST
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. Jan 31, 2019 - 06:59 PST
This incident affected: Forms.