Delay in Google Ads Audience Processing

Incident Report for Clearbit

Resolved

This incident has been resolved, Google Ads Audiences are processing normally.
Posted Jun 09, 2025 - 07:37 PDT

Monitoring

We've implemented a fix, and Google Ads Audience processing has resumed. Delayed jobs are now running, and we're monitoring the system to ensure everything runs as expected.
Posted Jun 06, 2025 - 14:50 PDT

Identified

We're currently experiencing an issue that's preventing Audiences from being processed for Google Ads. Processing will resume once a fix is in place. We're actively working to resolve the issue and will share updates as they become available.
Posted Jun 06, 2025 - 14:27 PDT
This incident affected: Dashboard.