Delayed Form and Event Processing
Incident Report for Clearbit
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 04, 2019 - 09:09 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. Apr 04, 2019 - 08:29 PDT
This incident affected: Forms.