Audience Alert Delay

Incident Report for Clearbit

Resolved

This incident has been resolved.
Posted Sep 12, 2023 - 17:11 PDT

Monitoring

We’re investigating an issue where audience alerts are not being delivered to some customers. We are working to identify the root cause and bring performance back to normal.
Posted Sep 12, 2023 - 14:27 PDT
This incident affected: Clearbit Data Activation Platform (Platform UI).