Delays in Batch Enrichment Processing

Incident Report for Clearbit

Resolved

This incident has been resolved - batch enrichment jobs are processing normally.
Posted Jul 30, 2025 - 12:21 PDT

Update

Batch enrichment processing is fully caught up. We're continuing to monitor to ensure stable performance.
Posted Jul 29, 2025 - 13:29 PDT

Monitoring

Batch enrichment processing has resumed, but a backlog remains. Some users may still experience delays as the system catches up. We're actively monitoring progress.
Posted Jul 28, 2025 - 15:01 PDT

Investigating

We're currently experiencing delays in processing batch enrichment jobs. Users who upload CSV files may see slower-than-expected processing times. In some cases, files may need to be re-submitted once the issue is resolved. We're actively working on a fix and will provide updates as we progress.
Posted Jul 28, 2025 - 13:10 PDT
This incident affected: Batch.