Segment Data Processing Delays
Incident Report for Clearbit
Resolved
This incident has been resolved.
Posted Aug 05, 2021 - 15:36 PDT
Investigating
Our data processing infrastructure is running behind which is causing inaccuracies in the reporting tools. No data has been lost and the system should be caught up shortly.
Posted Aug 05, 2021 - 14:36 PDT