X Emails temporarily delayed
Incident Report for Clearbit
Resolved
This incident has been resolved.
Posted Feb 25, 2020 - 14:24 PST
Investigating
We've identified an issue with our email provider, resulting in email deliveries being delayed. We are currently implementing a solution, and will update things are back to normal.
Posted Feb 25, 2020 - 14:20 PST
This incident affected: Clearbit X (API, UI, Forms).