Delayed Event Processing
Incident Report for Clearbit
Resolved
This incident has been resolved.
Posted Jan 25, 2019 - 12:14 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 25, 2019 - 10:06 PST
This incident affected: Forms.