Elevated API Errors
Incident Report for Clearbit
Resolved
This incident has been resolved.
Posted Dec 13, 2019 - 09:58 PST
Investigating
We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Dec 13, 2019 - 09:57 PST
This incident affected: Clearbit X (API).