Logs delayed
Incident Report for Clearbit
Resolved
This incident has been resolved.
Posted about 1 year ago. Sep 28, 2016 - 16:52 PDT
Monitoring
We upgrading the database behind clearbit.com/logs.

Logs will be delayed for a few hours.
Posted about 1 year ago. Sep 28, 2016 - 13:32 PDT