Unplanned downtime
Incident Report for Clearbit
Resolved
This issue has been resolved.
Posted about 1 year ago. Sep 09, 2016 - 08:54 PDT
Investigating
We are experiencing unplanned downtime. We expect to resume normal operations within a few minutes.
Posted about 1 year ago. Sep 09, 2016 - 08:41 PDT