Major outage
Incident Report for Clearbit
Resolved
We have resolved the issue and our systems are stabilizing now.
Posted about 1 year ago. Sep 09, 2016 - 14:44 PDT
Investigating
Our systems are suffering a major outage. We are investigating now and believe we have identified the issue.
Posted about 1 year ago. Sep 09, 2016 - 14:31 PDT