Logo API down

Incident Report for Clearbit

Resolved

Fixed - we had a huge spike in load which brought down some servers.
Posted Nov 05, 2015 - 10:05 PST

Investigating

We are currently investigating this issue.
Posted Nov 05, 2015 - 09:58 PST