API Log Processing Delay
Incident Report for Clearbit
Resolved
This incident has been resolved.
Posted 7 months ago. Feb 15, 2018 - 08:22 PST
Identified
The issue has been identified and a fix is being implemented.
Posted 7 months ago. Feb 14, 2018 - 08:16 PST