API Log Processing Delay
Incident Report for Clearbit
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 28, 2018 - 21:57 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. Jun 28, 2018 - 17:18 PDT
This incident affected: Dashboard.